11/09 2019

Simbolo diverso in Excel e altri simboli matematici

Esistono alcune funzioni di Microsoft Excel,  come ad esempio le funzioni logiche SE e PIÙ.SE, che rendono possibile “disegnare” percorsi o azioni differenti a seconda che il risultato di un test dia esito positivo o negativo.

In altre parole, con queste funzioni è possibile ordinare ad Excel di eseguire un certo calcolo a condizione che si verifichino determinate circostanze.

In questi casi, uno degli argomenti principali della funzione è il test che consiste in un’equazione o disequazione tra una cella e un valore:

ad esempio, A1 = “Mario” oppure A1 > 5.




Simboli matematici in Excel

Per utilizzare correttamente queste funzioni e per far si che il test sia esatto e che, di conseguenza, Excel calcoli in modo giusto il risultato, è importante conoscere bene tutti i simboli matematici che possono essere utilizzati in Excel.

Per questo motivo, di seguito trovate un comodissimo elenco di tutti gli operatori matematici che potete utilizzare:

  • Operatore    >      Significato: maggiore di – es. A1>5: il contenuto della cella A1 è maggiore di 5
  • Operatore    <      Significato: minore di – es. A1<5: il contenuto della cella A1 è minore di 5
  • Operatore    >=   Significato: maggiore o uguale a – es. A1>=5: il contenuto della cella A1 è maggiore o uguale a 5
  • Operatore    <=   Significato: minore o uguale a –  es. A1<=5: il contenuto della cella A1 è minore o uguale a 5
  • Operatore    =     Significato: uguale a – es. A1=5: il contenuto della cella A1 è uguale a 5
  • Operatore   <>    Significato: diverso da – es. A1<>5: il contenuto della cella A1 è diverso da 5




Simbolo diverso vs simbolo uguale: quando un dettaglio fa la differenza

 

Quando si usano questi operatori matematici all’interno delle funzioni è bene prestare molta attenzione perché, per ottenere un risultato esatto, dobbiamo essere certi di utilizzare il simbolo giusto, e di fare quindi ad Excel la giusta richiesta.

Infatti, per Excel non è la stessa cosa scrivere A1=A2 (simbolo uguale) oppure A1<>A2 (simbolo diverso), anzi, in questo caso, una espressione è esattamente l’opposto dell’altra, come nel caso A1<A2 o A1>A2.

 

Ad esempio, se la cella A1 contiene un numero e io voglio sapere se il valore contenuto nella cella A2 è maggiore, minore, uguale o diverso da quello della cella 1, devo fare attenzione a come scrivo la formula.

Infatti, se il valore di A1 è 5 e il valore di A2 è 7 se:

  • chiedo ad Excel =SE(A1>A2;”Vero”;”Falso”) otterrò FALSO, perché 5 NON È MAGGIORE di 7;
  • chiedo ad Excel =SE(A1<A2;”Vero”;”Falso”) otterrò VERO, perché 5 È MINORE di 7;
  • chiedo ad Excel =SE(A1=A2;”Vero”;”Falso”) otterrò FALSO, perché 5 NON È UGUALE da 7;
  • chiedo ad Excel =SE(A1<>A2;”Vero”;”Falso”) otterrò VERO, perché 5 È DIVERSO da 7.

*Nota: la sintassi della formula Se è la seguente: =se(test; azione se_vero; azione se_falso). In questi esempi, abbiamo deciso che se il test dava esito vero Excel doveva restituirmi il valore “Vero”, mentre se l’esito del test era falso doveva restituirmi il valore “Falso”.




One Comment

  1. Domenico De Luca says:

    Davvero molto soddisfacenti i video, complimenti!

Leave a Comment